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I. Install Ublox u-center Software

In order to configure the Ublox EVK-6 GPS receiver, you will need to install the supplied u-center software on a Windows computer.  If the software is not available on a CD, it can also be downloaded from the Ublox website (http://www.u-blox.com/en/evaluation-tools-a-software/u-center/u-center.html).  The most current version at the time of this writing is 6.20.  Note this document uses examples from u-center version 6.10 run on a Windows7 machine.
Section V below gives an overview on how to configure the receiver for the V2V-SP project.  Please check your specific requirements for different projects.  Additional information on configuring the receiver can be found in the u-center user guide supplied by Ublox.
II. Initial testing with USB connection
To test out and get familiar with the Ublox hardware and u-center software, you may want to use the USB connection.  Using the USB connection requires that you install the appropriate USB driver, which is available for download from Ublox at the following location:  http://www.u-blox.com/en/usb-drivers.html.  From this page, select the appropriate operating system.
After the USB driver has been installed, you can check if the computer recognizes the GPS receiver.  To do this, you will need to plug in the Ublox receiver using the supplied USB cable.  Go to the Windows "Device Manager", and select the "Ports" field to confirm that the Ublox receiver has been identified and determine the assigned COM port, as shown in Figure 1.
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Figure 1

III. Setting up the serial connection

The EVK-6 comes with both a USB and serial connector.  The USB connector should primarily be used for configuration and debugging, and to supply power to the receiver.  In order to use the Ublox receiver with the WSU, you will need to use the serial connection on the receiver (to get a PPS signal output).   By default, the serial connector has the correct pin out for communication with the WSU using a standard serial cable.  However, see precautions below to ensure Pin4 does not cause unwanted operation.
NOTE: When connecting the Ublox receiver to the WSU, the USB cable must also be connected to one of the WSU’s USB ports because the USB connection supplies power to the receiver.

NOTICE: Pin4 on the Ublox serial connection is used for external interrupts.  Since the WSU outputs constant 5V on Pin4, the WSU has the ability to trigger interrupts if a standard serial cable is used AND the interrupts are enabled.  If the interrupts are disabled, this will not likely cause a problem.  

The safest bet to ensure that Pin4 doesn't cause an issue would be to use a custom serial cable with Pin4 removed or disconnected.  You can easily make a cable by taking a standard serial cable and pulling out Pin4 with a pair of needle-nose pliers.
NOTE: If you decide to use a standard serial cable to connect the Ublox unit to the WSU, ensure that the External Interrupts is disabled.  They are disabled by default, but if they are turned on, it may cause unwanted behavior by the GPS receiver.  See Figures 10 thru 12and for menus used to verify the interrupts are disabled. 
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Figure 2

IV. Quick Configuration using USB connection and saved configuration file with u-center
Assuming that you already have a configuration file, all you need to do is connect your receiver to your laptop using the USB cable, start the u-center software, establish a connection with the receiver (Step 1 in section V below) and download the configuration file to the receiver (Step 14 in section V below).

The Ublox configuration file is saved as a .txt file. The saved configuration file should contain all appropriate UART, SBAS, PPS, and NMEA configurations, and you can create your own configuration file by following/modifying the steps in Section V.

To upload the configuration file to the GPS receiver, open the GPS configuration wizard, as shown in Figure 17, Step 12 under section V below.  The dialog box shown in Figure 18 will appear.  In the GPS Configuration dialog box, make sure to check the box next to "Store configuration intoBBR/Flash (non-volatile memory)."  You will need to get the desired configuration file by selecting the browse (…) button - you will then be prompted to select a location and file.  Next select the “File>>GPS” button to store the new settings to your receiver.  After this step is complete, you can power cycle your receiver, and check that the settings have been saved by opening the “View->Text Console” window, which displays the ASCII output from the receiver.   

V.  Manually configuring the receiver with u-center (Detailed Configuration)

1.  All configuration of the GPS receiver is done using the u-center software.  After starting u-center, connect the receiver to the same computer.  Select the appropriate baud rate as shown in Figure 3.  Starting with the USB connection, select the COM port assigned to the USB as shown in Figure 4 (the COM port assigned the USB connection can be verified as in section II above).  After the selecting the COM port, the software should connect automatically to the receiver.  You can verify successful connection by the status bar at the bottom of the screen - the connection icon will flash green.
NOTE: To manually configure the output on serial connection for the first time, you must be connected to the serial port on the receiver.  When connected to the serial port, all of the NMEA message configurations will only apply to the serial connection.  Similarly, if you are manually configuring the receiver using the USB connections, all message configurations will only apply to the USB port.  All other (non-output) configurations (such as data rate) apply the receiver and will affect both ports.  See step 10 for further information.
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Figure 3
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Figure 4
2.  After the receiver is connected, you can configure the settings on the receiver by going to the “View->Message View” screen, as shown in Figure 5.
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Figure 5
3.  From the Message View screen, the data output rate can be set by going to the UBX->CFG->RATE menu, as shown in Figure 6.  The rate is changed by editing the value in the "Measurement Period" box.  When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
NOTE: The maximum recommended data rate for the Ublox EVK-6 receiver is 5Hz (200ms).  However, we have been told the receiver can output at up to 10Hz (unconfirmed).
NOTE: This rate is the same for all NMEA messages; therefore, you can not configure the output rate of each message or port individually.
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Figure 6
4.  Once the rate has been set, you can then configure which messages you want the receiver to output (GPGGA, GPGSA, GPGST, & GPRMC are required by the WSU).  To turn on message output, go to the NMEA menu in the Message View window, and right-click on the desired message.  Then, choose the "Enable Message" option, as shown in Figure 7.  Do this for each message you want to enable.  To turn off a message, right-click on the desired message, then choose the “Disable Message” option.
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Figure 7
5.  The PPS output at the serial port is the compliment of the setting indicated in the software configuration.  To change the PPS output settings, go to the UBX->GFG->TP menu, as shown in Figure 8.  Ensure that the Pulse Mode is set to falling (not rising because setting it to falling will actually give you a rising edge at the serial port) edge, the Pulse Period is 1000ms (1second), and the Pulse Length is between 20-100ms (as per the WSU Users Guide).  When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
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Figure 8
6.  Configure the SBAS/WAAS mode by going to the UBX-CFG->SBAS menu.  Double-check that the SBAS settings are the same as shown in Figure 9.  If they are different, then change them to the default settings below.  When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
NOTE: The PRN Codes under the “Other” radio button are: 120, 122, 124, 126-127, 129, 131, 134-135, 137-138
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Figure 9

7.  Ensure that the external interrupts are disabled in software (especially if Pin4 is connected on the serial cable).   They should be disabled by default, but it is a good idea to double-check.   First go to the UBX->CFG->PM menu, and make sure the "EXTINT "high" keeps awake" and "EXINT "low" keeps awake" are NOT checked, as shown in Figure 10.  Next, go to the UBX->CFG->TM menu, and make sure "Enable Timemark" is NOT checked, as shown in Figure 11.  Finally, go to the UBX->GFG->TM2 menu, and make sure "Channel Enabled" is NOT checked, as shown in Figure 12.  When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
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Figure 10
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Figure 11
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Figure 12
8. Configure the Navigation mode by going to the UBX->CFG->NAV5 menu.  The receiver may have the “Dynamic Model” preconfigured to “2 – Stationary” as shown in Figure 13.   Leaving the configuration in the Stationary setting will result in unwanted behavior - the receiver to not output data if movement is detected.  Thus, the “Dynamic Model” setting must be changed.  Select “4 – Automotive” from the drop down menu next to the “Dynamic Model” label as shown in Figure 14.  When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
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Figure 13
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Figure 14
9. Configure the baud rate of the serial port by selecting the UBX->CFG->PRT menu.  From the drop down menu next to the “Baudrate” label, select the appropriate baud rate (normally 115200), as shown in Figure 15.   When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
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Figure 15

To configure the message output on the serial port, you must connect to COM port assigned to the serial connection.  Follow the instructions in Step 1 but instead select the serial connection COM port.  Then configure the NMEA messages as in Step 4.

10.  When finished making your configuration changes, save the configuration to the receivers non-volitile memory by going to the UBX->CFG-<CFG menu.  Ensure the “Save current configuration” radio button is selected as shown in Figure 16.  When finished editing the parameters in this window, select the “Send” button at the bottom of the main window.
[image: image16.png]u-center 610 -

- CFG (Config) - CFG. urati

6] Fie _Edt View Player Receiver Tools Window Help

‘DW

EERETICIE T Y 1=

- -m -

Amlnje(pr-»k —————— 4

vk Plaese »

& UBK
ACK (Acknowledge)
AID (GPS Aiding)
5 CFG (Config)
ANT (Antenna Settings)
[CFG (Configuration)]
DAT (Batum)
EKF (EKF Settings)
ESFGWT (Gyro+Wheeltick)
FXN (Fix Now Mode)
INF (nfMessages)
ITFM (Jamming/Interference Monitor)
LIC (License)
MSG (Messages)
NAV (Nevigation)
NAV2 (Navigation 2)
NAVS (Navigation 5)
NAVXS (Navigation Expert 5)
NMEA (NMEA Protocol)
NVS (Non-Volatil Storag)
PM (Power Management)
PM2 (Extended Power Management)
PRT (Ports)
RATE (Rates)
RINV Remote Inventory)
RST (Reset)

.
[F——
& | X | Hsend |20 [ | g8

[Ready

UBX - CFG (Config) - CFG (Configuration)

© Reverttolast saved configuation ¥ Devices (Romd)

© Revertal but ANT default configuration 0
1-FLAG

© Revert o defauit configuation

EEPROM

& Save curent configuration 4-SPLFLASH

© User defined operation

Ot Save Losd
T-FrT T-FRT

1Hom: 1Hom:

2. 2.

3 sy 3 sy

1R 1R

5-Lnused 5-Lnused

o Unused o Unused

7 nused 7 nused

3 Unueed 3 Unueed

3Ry 3Ry

10-aNT 10-aNT

11 - Urused 11 - Urused

12 Oused 12 Oused

13- Onused 13- Onused

13- nused 13- nused

15 nused 15 nused
0000 B5 62 06 09 OD 00 00 00 00 00 FF FF 00 00 00 00 00 00 ubdf3i3P3Pywlilidd -
0012 07 21 AF Fi

[Ebiczoll NoTcpey [NMEA  [ors6a1 163708 [¢





Figure 16

11. After setting all the configurations, you can save the settings from the Ublox receiver to file.  This will allow you to quickly configure your receiver, or to program other receivers with the identical configuration.  Open the “Tool->GPS Configuration…” dialog box, as shown in Figure 17.
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Figure 17
12.  The dialog box shown in Figure 18 will appear.  In the GPS Configuration dialog box, make sure to check the box next to "Store configuration intoBBR/Flash (non-volatile memory)."  To save the current configuration from the receiver – select the “GPS>>File” button.  You will then be prompted to select a location and file name to store the Configuration settings - the window shown in Figure 19 will appear, and you can choose an appropriate name for your file (ex. Ublox6T_Config.txt).   Press “Save” and the file will be created on your computer.

13.  Once a configuration file has been created, it can be reloaded using u-center.  Open the “GPS Configure again” dialog window from the “Tools->GPS Configuration…” menu.  Make sure to check the box next to "Store configuration intoBBR/Flash (non-volatile memory)."  You will need to get the desired configuration file by selecting the browse (…) button - you will then be prompted to select a location and file.  Next select the File>>GPS button to store the new settings to your receiver.  After this step is complete, you can power cycle your receiver, and check that the settings have been saved by opening the View->Text Console window, which displays the ASCII output from the receiver.   
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Figure 18
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Figure 19
